Dungeons 3 - Famous Last Words

  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
  • Dungeons 3 - Famous Last Words
This is a DLC. It requires the base game: Dungeons 3

About this game


“The Spirit of the Absolute Evil will run forever.”


Evil, evil everywhere, and there’s absolutely nothing Good left to conquer. No paladins, queens nor goddesses could stop the evil army’s triumphal march, and it will still be a while until the next generation of heroes will be come of age. So now, it’s time for the Finally-Bored-To-Death Evil to hang up its armour. But it wouldn’t be Dungeons if it didn’t end with the biggest of all bangs. While the Absolute Evil is making an excursion into the as-yet unconquered depths of its own nose in ‘Famous Last Words’ – out of pure boredom, obviously – a very heated discussion between Thalya and our beloved narrator erupts. Who will emerge victorious when these two luminous figures wrestle it out to become the ultimate warrior on the battlefield of evil? It’s time to find out…

  • A new, fully voiced campaign across 3 challenging maps.
  • New boss enemy – also available on Skirmish maps: The notorious Narrator with his spiffy skills.
  • New creep type – also available on Skirmish maps: The pesky Pen Pushers with their needle-pointed writing tools.

System requirements

Minimum:
Recommended:
Requires a 64-bit processor and operating system
Requires a 64-bit processor and operating system
Windows 7 64-bit
Windows 10 64-bit
Intel Quad Core 2.8 GHz (i7 900 series) or 3.5 GHz AMD (FX 6000 series)
Quad core 3.5 GHz or higher (Intel i5 4000 Series / AMD Ryzen 3 Series)
4 GB RAM
8 GB RAM
AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
Version 11
Version 11
Minimum:
Recommended:
Requires a 64-bit processor and operating system
Requires a 64-bit processor and operating system
OS X El Capitan (10.11)
OS X El Capitan (10.11)
2.8 GHz Quad Core
Quad core 3.5 GHz or higher
4 GB RAM
8 GB RAM
AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
Minimum:
Recommended:
Requires a 64-bit processor and operating system
Requires a 64-bit processor and operating system
Ubuntu 16.04.3 LTS + SteamOS (latest)
Ubuntu 16.04.3 LTS + SteamOS (latest)
Intel Quad Core 2.8 GHz (i7 900 series) or 3.5 GHz AMD (FX 6000 series)
Quad core 3.5 GHz or higher (Intel i5 4000 Series / AMD Ryzen 3 Series)
4 GB RAM
8 GB RAM
AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
Other Linux distributions (Mint, etc.) MIGHT work but we cannot give official support for them
Other Linux distributions (Mint, etc.) MIGHT work but we cannot give official support for them

Сomments